Skip to content
CVE PROGRAM SOURCE RECORD8.1 High

CVE-2021-21389

BuddyPress privilege escalation via REST API

Description

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

buddypress BuddyPress

  • >= 5.0.0, < 7.2.1affected

References