Skip to content
CVE PROGRAM SOURCE RECORD7.4 High

CVE-2021-21305

Code Injection vulnerability in CarrierWave

Description

CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The "#manipulate!" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

carrierwaveuploader carrierwave

  • < 1.3.2affected
  • >= 2.0.0, < 2.1.1affected

References