Description
In affected versions of WordPress, when uploading themes, the name of the theme folder can be crafted in a way that could lead to JavaScript execution in /wp-admin on the themes page. This does require an admin to upload the theme, and is low severity self-XSS. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
WordPress wordpress-develop
>= 5.4.0, < 5.4.2affected>= 5.3.0, < 5.3.4affected>= 5.2.0, < 5.2.7affected>= 5.1.0, < 5.1.6affected>= 5.0.0, < 5.0.10affected>= 4.9.0, < 4.9.15affected>= 4.8.0, < 4.8.14affected>= 4.7.0, < 4.7.18affected>= 4.6.0, < 4.6.19affected>= 4.5.0, < 4.5.22affected>= 4.4.0, < 4.4.23affected>= 4.3.0, < 4.3.24affected>= 4.2.0, < 4.2.28affected>= 4.1.0, < 4.1.31affected>= 4.0.0, < 4.0.31affected>= 3.9.0, < 3.9.32affected>= 3.8.0, < 3.8.34affected>= 3.7.0, < 3.7.34affected
References
- https://wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/ ↗
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-87h4-phjv-rm6p ↗
- https://github.com/WordPress/wordpress-develop/commit/404f397b4012fd9d382e55bf7d206c1317f01148 ↗
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ODNHXVJS25YVWYQHOCICXTLIN5UYJFDN/ ↗
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/773N2ZV7QEMBGKH6FBKI6Q5S3YJMW357/ ↗
- https://www.debian.org/security/2020/dsa-4709 ↗
- https://lists.debian.org/debian-lts-announce/2020/07/msg00000.html ↗
- https://lists.debian.org/debian-lts-announce/2020/09/msg00011.html ↗