Skip to content
CVE PROGRAM SOURCE RECORD6.8 Medium

CVE-2020-4047

Authenticated XSS via media attachment page in WordPress

Description

In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

WordPress wordpress-develop

  • >= 5.4.0, < 5.4.2affected
  • >= 5.3.0, < 5.3.4affected
  • >= 5.2.0, < 5.2.7affected
  • >= 5.1.0, < 5.1.6affected
  • >= 5.0.0, < 5.0.10affected
  • >= 4.9.0, < 4.9.15affected
  • >= 4.8.0, < 4.8.14affected
  • >= 4.7.0, < 4.7.18affected
  • >= 4.6.0, < 4.6.19affected
  • >= 4.5.0, < 4.5.22affected
  • >= 4.4.0, < 4.4.23affected
  • >= 4.3.0, < 4.3.24affected
  • >= 4.2.0, < 4.2.28affected
  • >= 4.1.0, < 4.1.31affected
  • >= 4.0.0, < 4.0.31affected
  • >= 3.9.0, < 3.9.32affected
  • >= 3.8.0, < 3.8.34affected
  • >= 3.7.0, < 3.7.34affected

References