Skip to content
CVE PROGRAM SOURCE RECORD7.7 High

CVE-2020-4043

Phar unserialization vulnerability in phpMussel

Description

phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

phpMussel phpMussel

  • >= 1.0.0, < 1.6.0affected

References