Skip to content
CVE PROGRAM SOURCE RECORD7.7 High

CVE-2020-26223

Authorization bypass in Spree

Description

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

spree spree

  • >= 3.7.0, < 3.7.13affected
  • >= 4.0.0, < 4.0.5affected
  • >= 4.1.0, < 4.1.12affected

References