Skip to content
CVE PROGRAM SOURCE RECORD5.5 Medium

CVE-2020-15704

pppd arbitrary file read information disclosure vulnerability

Description

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Canonical ppp

  • 2.4.5 to < 2.4.5-5ubuntu1.4affected
  • 2.4.7 to < 2.4.7-1+2ubuntu1.16.04.3affected

References