Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2020-15210

Segmentation fault in tensorflow-lite

Description

In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

tensorflow tensorflow

  • < 1.15.4affected
  • >= 2.0.0, < 2.0.3affected
  • >= 2.1.0, < 2.1.2affected
  • >= 2.2.0, < 2.2.1affected
  • >= 2.3.0, < 2.3.1affected

References