Description
Apache Camel Netty enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
n/a Apache Camel
Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0affected
References
- http://www.openwall.com/lists/oss-security/2020/05/14/9 ↗
- https://www.oracle.com/security-alerts/cpuoct2020.html ↗
- https://camel.apache.org/security/CVE-2020-11973.html ↗
- https://www.oracle.com/security-alerts/cpujan2021.html ↗
- https://www.oracle.com/security-alerts/cpuApr2021.html ↗
- https://www.oracle.com//security-alerts/cpujul2021.html ↗