Description
In Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and Puma 4.3.4.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
puma puma
< 3.12.5affected>= 4.0.0, < 4.3.4affected
References
- https://github.com/puma/puma/security/advisories/GHSA-x7jg-6pwg-fx5h ↗
- https://github.com/puma/puma/blob/master/History.md#434435-and-31253126--2020-05-22 ↗
- https://github.com/puma/puma/commit/f24d5521295a2152c286abb0a45a1e1e2bd275bd ↗
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00034.html ↗
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00038.html ↗
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SKIY5H67GJIGJL6SMFWFLUQQQR3EMVPR/ ↗
- https://lists.debian.org/debian-lts-announce/2020/10/msg00009.html ↗