Skip to content
CVE PROGRAM SOURCE RECORD6.9 Medium

CVE-2020-11023

Potential XSS vulnerability in jQuery

Description

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

jquery jQuery

  • >= 1.0.3, < 3.5.0affected

References