Skip to content
CVE PROGRAM SOURCE RECORD6.9 Medium

CVE-2020-11022

jQuery has a potential XSS vulnerability

Description

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

jquery jQuery

  • >= 1.12.0, < 3.5.0affected

References