Description
WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
WordPress WordPress
< 5.3.1 to < 5.3.1affected
References
- https://wpvulndb.com/vulnerabilities/9976 ↗
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-x3wp-h3qx-9w94 ↗
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/ ↗
- https://github.com/WordPress/wordpress-develop/commit/505dd6a20b6fc3d06130018c1caeff764248c29e ↗
- https://hackerone.com/reports/738644 ↗
- https://seclists.org/bugtraq/2020/Jan/8 ↗
- https://www.debian.org/security/2020/dsa-4599 ↗
- https://www.debian.org/security/2020/dsa-4677 ↗