Description
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Atlassian Crowd
2.1.0 to < unspecifiedaffectedunspecified to < 3.0.5affected3.1.0 to < unspecifiedaffectedunspecified to < 3.1.6affected3.2.0 to < unspecifiedaffectedunspecified to < 3.2.8affected3.3.0 to < unspecifiedaffectedunspecified to < 3.3.5affected3.4.0 to < unspecifiedaffectedunspecified to < 3.4.4affected