Description
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Kubernetes Kubernetes
prior to 1.13.12affectedprior to 1.14.8affectedprior to 1.15.5affectedprior to 1.16.2affected1.1affected1.2affected1.3affected1.4affected1.5affected1.6affected1.7affected1.8affected1.9affected1.10affected1.11affected1.12affected
References
- https://github.com/kubernetes/kubernetes/issues/83253 ↗
- https://groups.google.com/forum/#%21topic/kubernetes-security-announce/jk8polzSUxs ↗
- https://access.redhat.com/errata/RHSA-2019:3239 ↗
- https://security.netapp.com/advisory/ntap-20191031-0006/ ↗
- https://access.redhat.com/errata/RHSA-2019:3811 ↗
- https://access.redhat.com/errata/RHSA-2019:3905 ↗