Description
curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
n/a n/a
n/aaffected
References
- http://www.securityfocus.com/bid/104225 ↗
- https://lists.debian.org/debian-lts-announce/2018/05/msg00010.html ↗
- http://www.securitytracker.com/id/1040931 ↗
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html ↗
- https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html ↗
- https://access.redhat.com/errata/RHSA-2018:3558 ↗
- https://curl.haxx.se/docs/adv_2018-b138.html ↗
- https://access.redhat.com/errata/RHSA-2018:3157 ↗
- https://security.gentoo.org/glsa/201806-05 ↗
- https://www.debian.org/security/2018/dsa-4202 ↗
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html ↗
- https://usn.ubuntu.com/3648-1/ ↗
- https://usn.ubuntu.com/3598-2/ ↗
- https://access.redhat.com/errata/RHBA-2019:0327 ↗
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html ↗
- https://access.redhat.com/errata/RHSA-2020:0544 ↗
- https://access.redhat.com/errata/RHSA-2020:0594 ↗