Description
Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
n/a n/a
n/aaffected
References
- https://lists.debian.org/debian-lts-announce/2018/03/msg00034.html ↗
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html ↗
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.5.1_.2F_4.5.2_.282018-03-06.29 ↗
- https://access.redhat.com/errata/RHSA-2019:2276 ↗
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html ↗