Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
n/a n/a
n/aaffected
References
- https://www.debian.org/security/2018/dsa-4219 ↗
- https://usn.ubuntu.com/3621-1/ ↗
- https://access.redhat.com/errata/RHSA-2018:3729 ↗
- https://access.redhat.com/errata/RHSA-2018:3730 ↗
- https://access.redhat.com/errata/RHSA-2018:3731 ↗
- https://github.com/rubygems/rubygems/commit/1b931fc03b819b9a0214be3eaca844ef534175e2 ↗
- https://lists.debian.org/debian-lts-announce/2018/08/msg00028.html ↗
- https://www.debian.org/security/2018/dsa-4259 ↗
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html ↗
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html ↗
- https://access.redhat.com/errata/RHSA-2019:2028 ↗
- https://access.redhat.com/errata/RHSA-2020:0542 ↗
- https://access.redhat.com/errata/RHSA-2020:0591 ↗
- https://access.redhat.com/errata/RHSA-2020:0663 ↗