Skip to content
CVE PROGRAM SOURCE RECORD4.3 Medium

CVE-2014-125098

Dart http_server Directory Listing virtual_directory.dart VirtualDirectory cross site scripting

Description

A vulnerability was found in Dart http_server up to 0.9.5 and classified as problematic. Affected by this issue is the function VirtualDirectory of the file lib/src/virtual_directory.dart of the component Directory Listing Handler. The manipulation of the argument request.uri.path leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.9.6 is able to address this issue. The name of the patch is 27c1cbd8125bb0369e675eb72e48218496e48ffb. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225356.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Dart http_server

  • 0.9.0affected
  • 0.9.1affected
  • 0.9.2affected
  • 0.9.3affected
  • 0.9.4affected
  • 0.9.5affected

References