{"id":"CVE-2026-9731","state":"PUBLISHED","title":"Wp Js Detect <= 1.0.9 - Cross-Site Request Forgery to Plugin Settings Update","description":"The Wp Js Detect plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.9. This is due to missing or incorrect nonce validation on the plugin_settings function. This makes it possible for unauthenticated attackers to update the plugin's notification text and CSS settings (wp_non_js_notification_text and wp_non_js_notification_css), injecting arbitrary content that is echoed unescaped on the frontend via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2026-07-08T05:34:09.583Z","updatedAt":"2026-07-08T13:13:20.460Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["wpkuf Wp Js Detect"],"affected":[{"vendor":"wpkuf","product":"Wp Js Detect","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.9","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/afca7b14-f3bb-4612-b81c-bde120b380ba?source=cve","https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L193","https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L192","https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L190","https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L250"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:13:52.441Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/9xxx/CVE-2026-9731.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-9731","state":"PUBLISHED","datePublished":"2026-07-08T05:34:09.583Z","dateUpdated":"2026-07-08T13:13:20.460Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-05-27T17:24:04.304Z"},"containers":{"cna":{"title":"Wp Js Detect <= 1.0.9 - Cross-Site Request Forgery to Plugin Settings Update","descriptions":[{"lang":"en","value":"The Wp Js Detect plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.9. This is due to missing or incorrect nonce validation on the plugin_settings function. This makes it possible for unauthenticated attackers to update the plugin's notification text and CSS settings (wp_non_js_notification_text and wp_non_js_notification_css), injecting arbitrary content that is echoed unescaped on the frontend via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"wpkuf","product":"Wp Js Detect","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.9","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/afca7b14-f3bb-4612-b81c-bde120b380ba?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L193"},{"url":"https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L192"},{"url":"https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L190"},{"url":"https://plugins.trac.wordpress.org/browser/wp-js-detect/trunk/wp-js-detect.php#L250"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-07-08T05:34:09.583Z"},"credits":[{"lang":"en","type":"finder","value":"swat"}],"timeline":[{"time":"2026-07-07T16:31:16.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-08T13:13:12.998854Z","id":"CVE-2026-9731","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-08T13:13:20.460Z"}}]}}}