{"id":"CVE-2026-97077","state":"PUBLISHED","title":"WordPress Ad Inserter plugin <= 2.8.18 - Cross Site Scripting (XSS) vulnerability","description":"Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.18 versions.","publishedAt":"2026-09-30T12:27:52.515Z","updatedAt":"2026-09-30T13:27:07.680Z","severity":{"score":7.1,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L","source":"Patchstack"},"assigner":"Patchstack","products":["Spacetime Ad Inserter"],"affected":[{"vendor":"Spacetime","product":"Ad Inserter","packageName":"ad-inserter","defaultStatus":"unaffected","versions":[{"version":"n/a","status":"affected","lessThanOrEqual":"2.8.18","versionType":"custom","changes":[{"at":"2.8.19","status":"unaffected"}]}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerability/wordpress-ad-inserter-plugin-2-8-18-cross-site-scripting-xss-vulnerability?_s_id=cve"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:13:43.249Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/97xxx/CVE-2026-97077.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-97077","state":"PUBLISHED","datePublished":"2026-09-30T12:27:52.515Z","dateUpdated":"2026-09-30T13:27:07.680Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2026-09-24T00:20:10.982Z"},"containers":{"cna":{"title":"WordPress Ad Inserter plugin <= 2.8.18 - Cross Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.18 versions."}],"affected":[{"vendor":"Spacetime","product":"Ad Inserter","packageName":"ad-inserter","defaultStatus":"unaffected","versions":[{"version":"n/a","status":"affected","lessThanOrEqual":"2.8.18","versionType":"custom","changes":[{"at":"2.8.19","status":"unaffected"}]}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerability/wordpress-ad-inserter-plugin-2-8-18-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"REQUIRED","scope":"CHANGED","confidentialityImpact":"LOW","integrityImpact":"LOW","availabilityImpact":"LOW","version":"3.1","baseSeverity":"HIGH","baseScore":7.1,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-09-30T12:27:52.515Z"},"impacts":[{"capecId":"CAPEC-588","descriptions":[{"lang":"en","value":"CAPEC-588 DOM-Based XSS"}]}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Update the WordPress Ad Inserter plugin to the latest available version (at least 2.8.19)."}],"value":"Update the WordPress Ad Inserter plugin to the latest available version (at least 2.8.19)."}],"credits":[{"lang":"en","type":"finder","user":"00000000-0000-4000-9000-000000000000","value":"Asim Alshaya | Patchstack Bug Bounty Program"}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2026-97077","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2026-09-30T13:08:29.859436Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-09-30T13:27:07.680Z"}}]}}}