{"id":"CVE-2026-93909","state":"PUBLISHED","title":"IBM WebSphere Application Server Liberty is affected by an authentication bypass","description":"IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.10 is vulnerable by an authentication bypass vulnerability when samlWeb-2.0 feature is enabled.","publishedAt":"2026-10-13T20:18:18.736Z","updatedAt":"2026-10-14T14:08:40.761Z","severity":{"score":9.1,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server - Liberty"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.10","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server_liberty:17.0.0.3:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server_liberty:26.0.0.10:*:*:*:*:*:*:*"]}],"references":["https://www.ibm.com/support/pages/node/7292236"],"weaknesses":["CWE-384"],"ingestedAt":"2026-10-29T20:13:34.582Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/93xxx/CVE-2026-93909.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-93909","state":"PUBLISHED","datePublished":"2026-10-13T20:18:18.736Z","dateUpdated":"2026-10-14T14:08:40.761Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2026-09-18T20:50:11.214Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server Liberty is affected by an authentication bypass","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.10 is vulnerable by an authentication bypass vulnerability when samlWeb-2.0 feature is enabled."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.10","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server_liberty:17.0.0.3:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server_liberty:26.0.0.10:*:*:*:*:*:*:*"]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7292236","tags":["vendor-advisory","patch"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"NONE","baseSeverity":"CRITICAL","baseScore":9.1,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-384","lang":"en","description":"CWE-384 Session Fixation","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2026-10-13T20:18:18.736Z"},"solutions":[{"lang":"en","value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR DT502359. To determine if a feature is enabled for IBM WebSphere Application Server Liberty, refer to  How to determine if Liberty is using a specific feature https://www.ibm.com/support/pages/node/6553910 . \n\nFor IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.10 using the samlWeb-2.0 feature: \n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  DT502359 https://www.ibm.com/support/pages/node/7291426 \n--OR--\n· Apply Liberty Fix Pack 26.0.0.11 or later (targeted availability 4Q2026). \n\nAdditional interim fixes may be available and linked off the interim fix download page.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR DT502359. To determine if a feature is enabled for IBM WebSphere Application Server Liberty, refer to <a href=\"https://www.ibm.com/support/pages/node/6553910\" rel=\"nofollow\">How to determine if Liberty is using a specific feature</a>. <br/><br/><strong>For IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.10 using the samlWeb-2.0 feature: </strong><br/>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7291426\" rel=\"nofollow\">DT502359</a><br/>--OR--<br/>· Apply Liberty Fix Pack 26.0.0.11 or later (targeted availability 4Q2026). <br/><br/>Additional interim fixes may be available and linked off the interim fix download page.</p>"}]}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-10-14T14:08:31.414401Z","id":"CVE-2026-93909","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-14T14:08:40.761Z"}}]}}}