{"id":"CVE-2026-9022","state":"PUBLISHED","title":"Splide Carousel Block <= 1.7.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'url' Block Attribute","description":"The Splide Carousel Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'url' Block Attribute in all versions up to, and including, 1.7.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload must be published before it executes for site visitors, which requires an editor or administrator to approve and publish the contributor's post.","publishedAt":"2026-05-27T02:27:36.744Z","updatedAt":"2026-05-27T10:41:38.818Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["dkjensen Splide Carousel Block"],"affected":[{"vendor":"dkjensen","product":"Splide Carousel Block","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.7.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/268f2ae1-5360-4ec5-bcd9-dc3ab11396dc?source=cve","https://plugins.trac.wordpress.org/browser/splide-carousel/tags/1.7.1/build/carousel/view.js#L1","https://plugins.trac.wordpress.org/browser/splide-carousel/tags/1.7.1/build/carousel-item/index.js#L1","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3537643%40splide-carousel&new=3537643%40splide-carousel&sfp_email=&sfph_mail="],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:13:52.441Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/9xxx/CVE-2026-9022.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-9022","state":"PUBLISHED","datePublished":"2026-05-27T02:27:36.744Z","dateUpdated":"2026-05-27T10:41:38.818Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-05-19T15:14:09.718Z"},"containers":{"cna":{"title":"Splide Carousel Block <= 1.7.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'url' Block Attribute","descriptions":[{"lang":"en","value":"The Splide Carousel Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'url' Block Attribute in all versions up to, and including, 1.7.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload must be published before it executes for site visitors, which requires an editor or administrator to approve and publish the contributor's post."}],"affected":[{"vendor":"dkjensen","product":"Splide Carousel Block","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.7.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/268f2ae1-5360-4ec5-bcd9-dc3ab11396dc?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/splide-carousel/tags/1.7.1/build/carousel/view.js#L1"},{"url":"https://plugins.trac.wordpress.org/browser/splide-carousel/tags/1.7.1/build/carousel-item/index.js#L1"},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3537643%40splide-carousel&new=3537643%40splide-carousel&sfp_email=&sfph_mail="}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-05-27T02:27:36.744Z"},"credits":[{"lang":"en","type":"finder","value":"ZAST.AI"}],"timeline":[{"time":"2026-05-19T15:57:41.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-05-26T13:53:27.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-27T10:18:43.985680Z","id":"CVE-2026-9022","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-05-27T10:41:38.818Z"}}]}}}