{"id":"CVE-2026-89278","state":"PUBLISHED","title":"GPTranslate <= 2.34.6 - Unauthenticated Sensitive Information Exposure in Public Frontend Inline Script","description":"The GPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AI plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.34.6 via the enqueue_frontend_scripts. This makes it possible for unauthenticated attackers to extract the plaintext third-party AI provider API key (OpenAI, DeepL, xAI/Grok, Gemini, Claude, or Google Cloud Translation) — a credential granting billed account access — by fetching any public page and applying the inverse transformation bundled in the plugin's own public JavaScript asset. This exposure affects the default configuration (gpt-3.5-turbo in client mode) and all supported non-DeepSeek providers; only deepseek-* models and gpt-* models configured in server-proxy mode correctly suppress key emission.","publishedAt":"2026-09-18T06:38:56.059Z","updatedAt":"2026-09-18T14:31:43.944Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["john-dagelmore GPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AI"],"affected":[{"vendor":"john-dagelmore","product":"GPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AI","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.34.6","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/b7676362-4373-4c9a-b3cd-73fad9ff5477?source=cve","https://plugins.trac.wordpress.org/browser/gptranslate/tags/2.34.6/gptranslate.php#L2205","https://plugins.trac.wordpress.org/browser/gptranslate/tags/2.34.6/gptranslate.php#L2142","https://plugins.trac.wordpress.org/changeset?reponame=&old=3693232%40gptranslate&new=3693232%40gptranslate"],"weaknesses":["CWE-200"],"ingestedAt":"2026-10-29T20:13:26.108Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/89xxx/CVE-2026-89278.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-89278","state":"PUBLISHED","datePublished":"2026-09-18T06:38:56.059Z","dateUpdated":"2026-09-18T14:31:43.944Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-09-11T11:15:53.864Z"},"containers":{"cna":{"title":"GPTranslate <= 2.34.6 - Unauthenticated Sensitive Information Exposure in Public Frontend Inline Script","descriptions":[{"lang":"en","value":"The GPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AI plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.34.6 via the enqueue_frontend_scripts. This makes it possible for unauthenticated attackers to extract the plaintext third-party AI provider API key (OpenAI, DeepL, xAI/Grok, Gemini, Claude, or Google Cloud Translation) — a credential granting billed account access — by fetching any public page and applying the inverse transformation bundled in the plugin's own public JavaScript asset. This exposure affects the default configuration (gpt-3.5-turbo in client mode) and all supported non-DeepSeek providers; only deepseek-* models and gpt-* models configured in server-proxy mode correctly suppress key emission."}],"affected":[{"vendor":"john-dagelmore","product":"GPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AI","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.34.6","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/b7676362-4373-4c9a-b3cd-73fad9ff5477?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/gptranslate/tags/2.34.6/gptranslate.php#L2205"},{"url":"https://plugins.trac.wordpress.org/browser/gptranslate/tags/2.34.6/gptranslate.php#L2142"},{"url":"https://plugins.trac.wordpress.org/changeset?reponame=&old=3693232%40gptranslate&new=3693232%40gptranslate"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","baseScore":5.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-200","lang":"en","description":"CWE-200 Exposure of Sensitive Information to an Unauthorized Actor","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-09-18T06:38:56.059Z"},"credits":[{"lang":"en","type":"finder","value":"Supakiad S. (m3ez)"}],"timeline":[{"time":"2026-09-11T19:33:38.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-09-17T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2026-89278","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2026-09-18T14:16:33.671871Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-09-18T14:31:43.944Z"}}]}}}