{"id":"CVE-2026-84314","state":"PUBLISHED","title":"Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint","description":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.","publishedAt":"2026-10-12T20:47:51.561Z","updatedAt":"2026-10-13T17:32:02.947Z","severity":{"score":8.7,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["0xJacky nginx-ui"],"affected":[{"vendor":"0xJacky","product":"nginx-ui","versions":[{"version":"< 2.4.1","status":"affected"}]}],"references":["https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1"],"weaknesses":["CWE-285","CWE-862"],"ingestedAt":"2026-10-29T20:13:15.269Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/84xxx/CVE-2026-84314.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-84314","state":"PUBLISHED","datePublished":"2026-10-12T20:47:51.561Z","dateUpdated":"2026-10-13T17:32:02.947Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2026-09-01T16:17:43.079Z"},"containers":{"cna":{"title":"Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint","descriptions":[{"lang":"en","value":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1."}],"affected":[{"vendor":"0xJacky","product":"nginx-ui","versions":[{"version":"< 2.4.1","status":"affected"}]}],"references":[{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","name":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","name":"https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","tags":["x_refsource_MISC"]},{"url":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1","name":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":8.7,"baseSeverity":"HIGH","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","lang":"en","description":"CWE-285: Improper Authorization","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862: Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-10-12T20:47:51.561Z"},"source":{"advisory":"GHSA-2gc7-j998-5xx6","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","tags":["exploit"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-10-13T17:31:07.190328Z","id":"CVE-2026-84314","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-13T17:32:02.947Z"}}]}}}