{"id":"CVE-2026-8417","state":"PUBLISHED","title":"Concrete CMS 9.5.0 and below is vulnerable to CSRF in do_update() in the package update controller","description":"Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/update/do_update/<pkgHandle>. The do_update() method in concrete/controllers/single_page/dashboard/extend/update.php checks only canInstallPackages() before executing upgradeCoreData() and upgrade() on the named package's controller. Because the endpoint is a state-changing GET route with no token enforcement, an attacker can force an authenticated administrator to trigger a package upgrade via a single cross-site navigation.In order to be vulnerable, the victim must be passing canInstallPackages() and and a target package must already be already installed. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks  https://github.com/maru1009  for reporting.","publishedAt":"2026-05-21T20:19:42.643Z","updatedAt":"2026-05-22T12:14:28.774Z","severity":{"score":7.5,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"ConcreteCMS"},"assigner":"ConcreteCMS","products":["Concrete CMS Concrete CMS"],"affected":[{"vendor":"Concrete CMS","product":"Concrete CMS","defaultStatus":"unaffected","versions":[{"version":"5.0","status":"affected","lessThanOrEqual":"9.5.0","versionType":"git"}],"collectionURL":"https://github.com/concretecms/concretecms","repo":"https://github.com/concretecms/concretecms"}],"references":["https://documentation.concretecms.org/9-x/developers/introduction/version-history/951-release-notes"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:13:26.108Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/8xxx/CVE-2026-8417.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-8417","state":"PUBLISHED","datePublished":"2026-05-21T20:19:42.643Z","dateUpdated":"2026-05-22T12:14:28.774Z","assignerShortName":"ConcreteCMS","assignerOrgId":"ff5b8ace-8b95-4078-9743-eac1ca5451de","dateReserved":"2026-05-12T17:34:46.172Z"},"containers":{"cna":{"title":"Concrete CMS 9.5.0 and below is vulnerable to CSRF in do_update() in the package update controller","descriptions":[{"lang":"en","value":"Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/update/do_update/<pkgHandle>. The do_update() method in concrete/controllers/single_page/dashboard/extend/update.php checks only canInstallPackages() before executing upgradeCoreData() and upgrade() on the named package's controller. Because the endpoint is a state-changing GET route with no token enforcement, an attacker can force an authenticated administrator to trigger a package upgrade via a single cross-site navigation.In order to be vulnerable, the victim must be passing canInstallPackages() and and a target package must already be already installed. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks  https://github.com/maru1009  for reporting."}],"affected":[{"vendor":"Concrete CMS","product":"Concrete CMS","defaultStatus":"unaffected","versions":[{"version":"5.0","status":"affected","lessThanOrEqual":"9.5.0","versionType":"git"}],"collectionURL":"https://github.com/concretecms/concretecms","repo":"https://github.com/concretecms/concretecms"}],"references":[{"url":"https://documentation.concretecms.org/9-x/developers/introduction/version-history/951-release-notes","tags":["release-notes"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"HIGH","attackRequirements":"PRESENT","privilegesRequired":"NONE","userInteraction":"ACTIVE","vulnConfidentialityImpact":"HIGH","subConfidentialityImpact":"NONE","vulnIntegrityImpact":"HIGH","subIntegrityImpact":"NONE","vulnAvailabilityImpact":"HIGH","subAvailabilityImpact":"NONE","exploitMaturity":"NOT_DEFINED","Safety":"NOT_DEFINED","Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","valueDensity":"NOT_DEFINED","vulnerabilityResponseEffort":"NOT_DEFINED","providerUrgency":"NOT_DEFINED","version":"4.0","baseSeverity":"HIGH","baseScore":7.5,"vectorString":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site request forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"ConcreteCMS","orgId":"ff5b8ace-8b95-4078-9743-eac1ca5451de","dateUpdated":"2026-05-21T20:19:42.643Z"},"impacts":[{"capecId":"CAPEC-467","descriptions":[{"lang":"en","value":"CAPEC-467 Cross Site Identification"}]}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 1.0.2"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-22T12:14:16.961823Z","id":"CVE-2026-8417","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-05-22T12:14:28.774Z"}}]}}}