{"id":"CVE-2026-77936","state":"PUBLISHED","title":"Letta through 0.16.8 Insecure Default Configuration Unauthenticated API and PostgreSQL Access","description":"Letta through 0.16.8 ships a compose.yaml that does not enable LETTA_SERVER_SECURE, so the password middleware is never added and all API routes are unauthenticated, and it exposes a superuser PostgreSQL port with default credentials. Remote attackers can execute arbitrary Python via POST /v1/tools/run, manage /v1/admin users, or run OS commands via COPY PROGRAM.","publishedAt":"2026-10-20T00:46:14.144Z","updatedAt":"2026-10-20T16:07:28.161Z","severity":{"score":9.3,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["letta-ai letta"],"affected":[{"vendor":"letta-ai","product":"letta","packageURL":"pkg:pypi/letta","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.16.8","versionType":"semver"}],"collectionURL":"https://pypi.org","repo":"https://github.com/letta-ai/letta"}],"references":["https://www.lasso.security/vulnerability-database/cve-2026-77936","https://github.com/letta-ai/letta/blob/1131535716e8a31c9a437f8695e25ac98f203a24/compose.yaml#L17","https://github.com/letta-ai/letta/blob/1131535716e8a31c9a437f8695e25ac98f203a24/letta/server/rest_api/app.py#L799","https://www.vulncheck.com/advisories/letta-through-0.16.8-insecure-default-configuration-unauthenticated-api-and-postgresql-access"],"weaknesses":["CWE-1188"],"ingestedAt":"2026-10-29T20:13:07.220Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/77xxx/CVE-2026-77936.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-77936","state":"PUBLISHED","datePublished":"2026-10-20T00:46:14.144Z","dateUpdated":"2026-10-20T16:07:28.161Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-08-21T17:52:36.080Z"},"containers":{"cna":{"title":"Letta through 0.16.8 Insecure Default Configuration Unauthenticated API and PostgreSQL Access","descriptions":[{"lang":"en","value":"Letta through 0.16.8 ships a compose.yaml that does not enable LETTA_SERVER_SECURE, so the password middleware is never added and all API routes are unauthenticated, and it exposes a superuser PostgreSQL port with default credentials. Remote attackers can execute arbitrary Python via POST /v1/tools/run, manage /v1/admin users, or run OS commands via COPY PROGRAM."}],"affected":[{"vendor":"letta-ai","product":"letta","packageURL":"pkg:pypi/letta","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.16.8","versionType":"semver"}],"collectionURL":"https://pypi.org","repo":"https://github.com/letta-ai/letta"}],"references":[{"url":"https://www.lasso.security/vulnerability-database/cve-2026-77936","tags":["technical-description","exploit"],"name":"Lasso.security Advisory"},{"url":"https://github.com/letta-ai/letta/blob/1131535716e8a31c9a437f8695e25ac98f203a24/compose.yaml#L17","tags":["technical-description"]},{"url":"https://github.com/letta-ai/letta/blob/1131535716e8a31c9a437f8695e25ac98f203a24/letta/server/rest_api/app.py#L799","tags":["technical-description"]},{"url":"https://www.vulncheck.com/advisories/letta-through-0.16.8-insecure-default-configuration-unauthenticated-api-and-postgresql-access","name":"VulnCheck Advisory: Letta through 0.16.8 Insecure Default Configuration Unauthenticated API and PostgreSQL Access","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","cvssV4_0":{"version":"4.0","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":9.3,"baseSeverity":"CRITICAL"}},{"format":"CVSS","cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"HIGH","baseScore":9.8,"baseSeverity":"CRITICAL"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-1188","lang":"en","description":"Initialization of a Resource with an Insecure Default","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-10-20T00:46:14.144Z"},"datePublic":"2026-10-18T00:00:00.000Z","tags":["unsupported-when-assigned"],"cpeApplicability":[{"nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:letta:letta:*:*:*:*:*:*:*:*","versionEndIncluding":"0.16.8"}]}]}],"credits":[{"lang":"en","value":"Noy Pearl","type":"finder"},{"lang":"en","value":"Michael Sromin","type":"finder"},{"lang":"en","value":"Ophir Dror","type":"finder"}],"x_generator":{"engine":"vulncheck-endgame"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-10-20T16:04:32.766807Z","id":"CVE-2026-77936","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-20T16:07:28.161Z"}}]}}}