{"id":"CVE-2026-77183","state":"PUBLISHED","title":"FooSales <= 1.43.0 - Authenticated (Custom+) Privilege Escalation via create_update_customer REST Endpoint","description":"The FooSales – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.43.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with FooSales Cashier-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.","publishedAt":"2026-10-10T05:31:01.973Z","updatedAt":"2026-10-11T16:55:17.453Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["foosales FooSales – Point of Sale (POS) for WooCommerce"],"affected":[{"vendor":"foosales","product":"FooSales – Point of Sale (POS) for WooCommerce","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.43.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/97097d41-1d78-4db0-8ee2-70a776bd99f2?source=cve","https://plugins.trac.wordpress.org/changeset/3719657/foosales/trunk/admin/class-foosales-rest-api.php","https://plugins.trac.wordpress.org/changeset/3719657/foosales/trunk/admin/foosales-xmlrpc-functions.php"],"weaknesses":["CWE-269"],"ingestedAt":"2026-10-29T20:13:07.220Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/77xxx/CVE-2026-77183.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-77183","state":"PUBLISHED","datePublished":"2026-10-10T05:31:01.973Z","dateUpdated":"2026-10-11T16:55:17.453Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-08-20T15:39:24.587Z"},"containers":{"cna":{"title":"FooSales <= 1.43.0 - Authenticated (Custom+) Privilege Escalation via create_update_customer REST Endpoint","descriptions":[{"lang":"en","value":"The FooSales – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.43.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with FooSales Cashier-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account."}],"affected":[{"vendor":"foosales","product":"FooSales – Point of Sale (POS) for WooCommerce","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.43.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/97097d41-1d78-4db0-8ee2-70a776bd99f2?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3719657/foosales/trunk/admin/class-foosales-rest-api.php"},{"url":"https://plugins.trac.wordpress.org/changeset/3719657/foosales/trunk/admin/foosales-xmlrpc-functions.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-269","lang":"en","description":"CWE-269 Improper Privilege Management","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-10-10T05:31:01.973Z"},"credits":[{"lang":"en","type":"finder","value":"Supakiad S. (m3ez)"}],"timeline":[{"time":"2026-08-02T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2026-10-09T17:06:52.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2026-77183","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"version":"2.0.3","timestamp":"2026-10-11T16:38:00.473589Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-11T16:55:17.453Z"}}]}}}