{"id":"CVE-2026-76801","state":"PUBLISHED","title":"FireBox <= 3.1.10 - Authenticated (Author+) Remote Code Execution to Privilege Escalation","description":"The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.","publishedAt":"2026-09-09T02:27:34.997Z","updatedAt":"2026-09-09T13:56:02.046Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["fireplugins FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment"],"affected":[{"vendor":"fireplugins","product":"FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.1.10","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/9c1d8ec3-de01-4496-8d8b-b9604f952b1e?source=cve","https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Conditions/Conditions/PHP.php#L36","https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Executer.php#L231","https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/FB/Meta.php#L411","https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/Migrator.php#L606","https://plugins.trac.wordpress.org/changeset?reponame=&old=3666018%40firebox&new=3666018%40firebox"],"weaknesses":["CWE-269"],"ingestedAt":"2026-10-29T20:12:58.252Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/76xxx/CVE-2026-76801.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-76801","state":"PUBLISHED","datePublished":"2026-09-09T02:27:34.997Z","dateUpdated":"2026-09-09T13:56:02.046Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-08-19T19:45:45.314Z"},"containers":{"cna":{"title":"FireBox <= 3.1.10 - Authenticated (Author+) Remote Code Execution to Privilege Escalation","descriptions":[{"lang":"en","value":"The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access."}],"affected":[{"vendor":"fireplugins","product":"FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.1.10","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/9c1d8ec3-de01-4496-8d8b-b9604f952b1e?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Conditions/Conditions/PHP.php#L36"},{"url":"https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Executer.php#L231"},{"url":"https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/FB/Meta.php#L411"},{"url":"https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/Migrator.php#L606"},{"url":"https://plugins.trac.wordpress.org/changeset?reponame=&old=3666018%40firebox&new=3666018%40firebox"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-269","lang":"en","description":"CWE-269 Improper Privilege Management","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-09-09T02:27:34.997Z"},"credits":[{"lang":"en","type":"finder","value":"Wordfence PRISM"}],"timeline":[{"time":"2026-08-19T20:01:09.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-09-08T13:51:53.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-09-09T13:55:52.959167Z","id":"CVE-2026-76801","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-09-09T13:56:02.046Z"}}]}}}