{"id":"CVE-2026-76212","state":"PUBLISHED","title":"phpMyFAQ before 4.1.7 LIKE Wildcard Injection via PostgreSQL","description":"phpMyFAQ before 4.1.7, when configured to use PostgreSQL via the native pgsql PHP extension, declares an incorrect LIKE ESCAPE character ('=') in the Search/Database/Pgsql.php backend while escapeLikeWildcards() escapes user input with the '|' prefix. As a result, wildcard escaping is a no-op and user-supplied % and _ characters remain active LIKE wildcards. An unauthenticated attacker can submit such characters in the public FAQ search form to force maximally broad pattern matches and expensive sequential scans, resulting in a denial of service. The PDO PostgreSQL backend is not affected, and quotes remain escaped so this does not enable quote-breaking SQL injection or data exfiltration.","publishedAt":"2026-08-19T14:01:58.591Z","updatedAt":"2026-08-25T01:55:21.857Z","severity":{"score":6.9,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["thorsten phpMyFAQ"],"affected":[{"vendor":"thorsten","product":"phpMyFAQ","defaultStatus":"unaffected","versions":[{"version":"4.2.0-alpha","status":"affected","lessThan":"4.1.7","versionType":"semver"},{"version":"4.1.7","status":"unaffected","versionType":"semver"}]}],"references":["https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-5hx6-c293-588h","https://www.vulncheck.com/advisories/phpmyfaq-before-like-wildcard-injection-via-postgresql"],"weaknesses":["CWE-88"],"ingestedAt":"2026-10-29T20:12:58.252Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/76xxx/CVE-2026-76212.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-76212","state":"PUBLISHED","datePublished":"2026-08-19T14:01:58.591Z","dateUpdated":"2026-08-25T01:55:21.857Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-08-19T11:34:28.577Z"},"containers":{"cna":{"title":"phpMyFAQ before 4.1.7 LIKE Wildcard Injection via PostgreSQL","descriptions":[{"lang":"en","value":"phpMyFAQ before 4.1.7, when configured to use PostgreSQL via the native pgsql PHP extension, declares an incorrect LIKE ESCAPE character ('=') in the Search/Database/Pgsql.php backend while escapeLikeWildcards() escapes user input with the '|' prefix. As a result, wildcard escaping is a no-op and user-supplied % and _ characters remain active LIKE wildcards. An unauthenticated attacker can submit such characters in the public FAQ search form to force maximally broad pattern matches and expensive sequential scans, resulting in a denial of service. The PDO PostgreSQL backend is not affected, and quotes remain escaped so this does not enable quote-breaking SQL injection or data exfiltration."}],"affected":[{"vendor":"thorsten","product":"phpMyFAQ","defaultStatus":"unaffected","versions":[{"version":"4.2.0-alpha","status":"affected","lessThan":"4.1.7","versionType":"semver"},{"version":"4.1.7","status":"unaffected","versionType":"semver"}]}],"references":[{"url":"https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-5hx6-c293-588h","tags":["vendor-advisory"],"name":"GitHub Security Advisory (GHSA-5hx6-c293-588h)"},{"url":"https://www.vulncheck.com/advisories/phpmyfaq-before-like-wildcard-injection-via-postgresql","name":"VulnCheck Advisory: phpMyFAQ before 4.1.7 LIKE Wildcard Injection via PostgreSQL","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","cvssV4_0":{"version":"4.0","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"LOW","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":6.9,"baseSeverity":"MEDIUM"}},{"format":"CVSS","cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"NONE","integrityImpact":"NONE","availabilityImpact":"LOW","baseScore":5.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-88","lang":"en","description":"Improper Neutralization of Argument Delimiters in a Command ('Argument Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-08-19T14:01:58.591Z"},"datePublic":"2026-08-04T00:00:00.000Z","cpeApplicability":[{"nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:*","versionStartIncluding":"4.2.0","versionEndExcluding":"4.1.7"}]}]}],"credits":[{"lang":"en","value":"arpitjain099","type":"reporter"}],"x_generator":{"engine":"vulncheck-endgame"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-5hx6-c293-588h","tags":["exploit"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-08-25T01:54:57.342908Z","id":"CVE-2026-76212","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-08-25T01:55:21.857Z"}}]}}}