{"id":"CVE-2026-7614","state":"PUBLISHED","title":"Old Posts Highlighter <= 1.0.3 - Cross-Site Request Forgery to Settings Update","description":"The Old Posts Highlighter plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.3. This is due to missing or incorrect nonce validation on the OPH_options function. This makes it possible for unauthenticated attackers to update the plugin's configuration settings without authorization via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2026-05-27T05:31:30.232Z","updatedAt":"2026-05-27T10:33:22.135Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["mkhfr Old Posts Highlighter"],"affected":[{"vendor":"mkhfr","product":"Old Posts Highlighter","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/c186d5eb-abc2-47bd-9d3c-2b2f24d2f87e?source=cve","https://plugins.trac.wordpress.org/browser/old-posts-highlighter/trunk/OPH_admin.php#L37","https://plugins.trac.wordpress.org/browser/old-posts-highlighter/tags/1.0.3/OPH_admin.php#L37","https://plugins.trac.wordpress.org/browser/old-posts-highlighter/trunk/OPH_admin.php#L163","https://plugins.trac.wordpress.org/browser/old-posts-highlighter/tags/1.0.3/OPH_admin.php#L163"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:13:07.220Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/7xxx/CVE-2026-7614.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-7614","state":"PUBLISHED","datePublished":"2026-05-27T05:31:30.232Z","dateUpdated":"2026-05-27T10:33:22.135Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-05-01T13:10:03.590Z"},"containers":{"cna":{"title":"Old Posts Highlighter <= 1.0.3 - Cross-Site Request Forgery to Settings Update","descriptions":[{"lang":"en","value":"The Old Posts Highlighter plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.3. This is due to missing or incorrect nonce validation on the OPH_options function. This makes it possible for unauthenticated attackers to update the plugin's configuration settings without authorization via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"mkhfr","product":"Old Posts Highlighter","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/c186d5eb-abc2-47bd-9d3c-2b2f24d2f87e?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/old-posts-highlighter/trunk/OPH_admin.php#L37"},{"url":"https://plugins.trac.wordpress.org/browser/old-posts-highlighter/tags/1.0.3/OPH_admin.php#L37"},{"url":"https://plugins.trac.wordpress.org/browser/old-posts-highlighter/trunk/OPH_admin.php#L163"},{"url":"https://plugins.trac.wordpress.org/browser/old-posts-highlighter/tags/1.0.3/OPH_admin.php#L163"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-05-27T05:31:30.232Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Afnaan"}],"timeline":[{"time":"2026-05-26T17:20:51.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-27T10:16:39.241616Z","id":"CVE-2026-7614","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-05-27T10:33:22.135Z"}}]}}}