{"id":"CVE-2026-74792","state":"PUBLISHED","title":"Scriban before 7.0.0 Stack Overflow via nested array initializers","description":"Scriban before 7.0.0 (affected versions <= 6.6.0) contains a stack overflow vulnerability in nested array initializer parsing. Deeply nested array initializers recurse through a path (ParseArrayInitializer → ParseExpression → ParseArrayInitializer) that is not covered by the ExpressionDepthLimit counter added in the fix for GHSA-wgh7-7m3c-fx25. An attacker who can supply untrusted input to Template.Parse can trigger an uncatchable StackOverflowException that immediately terminates the process, even with the default ExpressionDepthLimit enabled.","publishedAt":"2026-08-16T13:14:15.706Z","updatedAt":"2026-08-18T14:08:24.056Z","severity":{"score":8.7,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["scriban scriban"],"affected":[{"vendor":"scriban","product":"scriban","packageURL":"pkg:nuget/Scriban","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"7.0.0","versionType":"semver"},{"version":"7.0.0","status":"unaffected","versionType":"semver"}]}],"references":["https://github.com/scriban/scriban/security/advisories/GHSA-p6q4-fgr8-vx4p","https://www.vulncheck.com/advisories/scriban-before-stack-overflow-via-nested-array-initializers"],"weaknesses":["CWE-674"],"ingestedAt":"2026-10-29T20:12:58.252Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/74xxx/CVE-2026-74792.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-74792","state":"PUBLISHED","datePublished":"2026-08-16T13:14:15.706Z","dateUpdated":"2026-08-18T14:08:24.056Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-08-16T12:56:02.577Z"},"containers":{"cna":{"title":"Scriban before 7.0.0 Stack Overflow via nested array initializers","descriptions":[{"lang":"en","value":"Scriban before 7.0.0 (affected versions <= 6.6.0) contains a stack overflow vulnerability in nested array initializer parsing. Deeply nested array initializers recurse through a path (ParseArrayInitializer → ParseExpression → ParseArrayInitializer) that is not covered by the ExpressionDepthLimit counter added in the fix for GHSA-wgh7-7m3c-fx25. An attacker who can supply untrusted input to Template.Parse can trigger an uncatchable StackOverflowException that immediately terminates the process, even with the default ExpressionDepthLimit enabled."}],"affected":[{"vendor":"scriban","product":"scriban","packageURL":"pkg:nuget/Scriban","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"7.0.0","versionType":"semver"},{"version":"7.0.0","status":"unaffected","versionType":"semver"}]}],"references":[{"url":"https://github.com/scriban/scriban/security/advisories/GHSA-p6q4-fgr8-vx4p","tags":["vendor-advisory"],"name":"GitHub Security Advisory (GHSA-p6q4-fgr8-vx4p)"},{"url":"https://www.vulncheck.com/advisories/scriban-before-stack-overflow-via-nested-array-initializers","name":"VulnCheck Advisory: Scriban before 7.0.0 Stack Overflow via nested array initializers","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","cvssV4_0":{"version":"4.0","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":8.7,"baseSeverity":"HIGH"}},{"format":"CVSS","cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"NONE","integrityImpact":"NONE","availabilityImpact":"HIGH","baseScore":7.5,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-674","lang":"en","description":"Uncontrolled Recursion","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-08-16T13:14:15.706Z"},"datePublic":"2026-03-22T00:00:00.000Z","credits":[{"lang":"en","value":"pawlos","type":"reporter"}],"x_generator":{"engine":"vulncheck-endgame"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://github.com/scriban/scriban/security/advisories/GHSA-p6q4-fgr8-vx4p","tags":["exploit"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-08-18T14:07:56.692914Z","id":"CVE-2026-74792","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-08-18T14:08:24.056Z"}}]}}}