{"id":"CVE-2026-6415","state":"PUBLISHED","title":"Advanced Custom Fields: Font Awesome Field <= 5.0.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via JSON Field","description":"The Advanced Custom Fields: Font Awesome plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to and including 5.0.2. This is due to insufficient input validation of JSON field values and unsafe client-side HTML construction in the update_preview() JavaScript function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2026-05-15T07:46:38.632Z","updatedAt":"2026-05-15T11:09:04.014Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["justinkruit Advanced Custom Fields: Font Awesome Field"],"affected":[{"vendor":"justinkruit","product":"Advanced Custom Fields: Font Awesome Field","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.0.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/a7a53ba2-e983-4821-b3de-105a96b7cb0e?source=cve","https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/trunk/assets/js/input-v6.js#L11","https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/tags/5.0.2/assets/js/input-v6.js#L11","https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/trunk/assets/js/input-v6.js#L12","https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/tags/5.0.2/assets/js/input-v6.js#L12","https://plugins.trac.wordpress.org/changeset/3525840/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:12:49.727Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/6xxx/CVE-2026-6415.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-6415","state":"PUBLISHED","datePublished":"2026-05-15T07:46:38.632Z","dateUpdated":"2026-05-15T11:09:04.014Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-04-15T23:52:53.449Z"},"containers":{"cna":{"title":"Advanced Custom Fields: Font Awesome Field <= 5.0.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via JSON Field","descriptions":[{"lang":"en","value":"The Advanced Custom Fields: Font Awesome plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to and including 5.0.2. This is due to insufficient input validation of JSON field values and unsafe client-side HTML construction in the update_preview() JavaScript function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"justinkruit","product":"Advanced Custom Fields: Font Awesome Field","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.0.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/a7a53ba2-e983-4821-b3de-105a96b7cb0e?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/trunk/assets/js/input-v6.js#L11"},{"url":"https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/tags/5.0.2/assets/js/input-v6.js#L11"},{"url":"https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/trunk/assets/js/input-v6.js#L12"},{"url":"https://plugins.trac.wordpress.org/browser/advanced-custom-fields-font-awesome/tags/5.0.2/assets/js/input-v6.js#L12"},{"url":"https://plugins.trac.wordpress.org/changeset/3525840/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-05-15T07:46:38.632Z"},"credits":[{"lang":"en","type":"finder","value":"Nguyen Cong Quang"}],"timeline":[{"time":"2026-05-14T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-15T11:08:51.907371Z","id":"CVE-2026-6415","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-05-15T11:09:04.014Z"}}]}}}