{"id":"CVE-2026-62193","state":"PUBLISHED","title":"OpenClaw 2026.6.5 < 2026.6.9 Authentication Bypass via Plugin Install","description":"OpenClaw versions 2026.6.5 before 2026.6.9 contain a vulnerability in the plugin install wrappers that could skip the install policy (authorization) check. When the affected feature is enabled and reachable, a lower-trust caller or a configured input path could execute or persist actions beyond the caller's intended authorization. Impact depends on the operator's configuration and whether lower-trust input can reach the affected path. The issue is fixed in 2026.6.9.","publishedAt":"2026-07-13T21:30:15.450Z","updatedAt":"2026-07-15T14:26:14.293Z","severity":{"score":6.9,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["OpenClaw OpenClaw"],"affected":[{"vendor":"OpenClaw","product":"OpenClaw","packageURL":"pkg:npm/openclaw","defaultStatus":"unaffected","versions":[{"version":"2026.6.5","status":"affected","lessThan":"2026.6.9","versionType":"semver"},{"version":"2026.6.9","status":"unaffected","versionType":"semver"}],"repo":"https://github.com/openclaw/openclaw"}],"references":["https://github.com/openclaw/openclaw/security/advisories/GHSA-wgq8-x5wm-g4rw","https://www.vulncheck.com/advisories/openclaw-authentication-bypass-via-plugin-install"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T20:12:32.778Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/62xxx/CVE-2026-62193.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-62193","state":"PUBLISHED","datePublished":"2026-07-13T21:30:15.450Z","dateUpdated":"2026-07-15T14:26:14.293Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-07-13T16:36:32.095Z"},"containers":{"cna":{"title":"OpenClaw 2026.6.5 < 2026.6.9 Authentication Bypass via Plugin Install","descriptions":[{"lang":"en","value":"OpenClaw versions 2026.6.5 before 2026.6.9 contain a vulnerability in the plugin install wrappers that could skip the install policy (authorization) check. When the affected feature is enabled and reachable, a lower-trust caller or a configured input path could execute or persist actions beyond the caller's intended authorization. Impact depends on the operator's configuration and whether lower-trust input can reach the affected path. The issue is fixed in 2026.6.9."}],"affected":[{"vendor":"OpenClaw","product":"OpenClaw","packageURL":"pkg:npm/openclaw","defaultStatus":"unaffected","versions":[{"version":"2026.6.5","status":"affected","lessThan":"2026.6.9","versionType":"semver"},{"version":"2026.6.9","status":"unaffected","versionType":"semver"}],"repo":"https://github.com/openclaw/openclaw"}],"references":[{"url":"https://github.com/openclaw/openclaw/security/advisories/GHSA-wgq8-x5wm-g4rw","name":"GitHub Security Advisory (GHSA-wgq8-x5wm-g4rw)","tags":["vendor-advisory"]},{"url":"https://www.vulncheck.com/advisories/openclaw-authentication-bypass-via-plugin-install","name":"VulnCheck Advisory: OpenClaw 2026.6.5 < 2026.6.9 Authentication Bypass via Plugin Install","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"HIGH","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","subConfidentialityImpact":"NONE","vulnIntegrityImpact":"HIGH","subIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subAvailabilityImpact":"NONE","exploitMaturity":"NOT_DEFINED","Safety":"NOT_DEFINED","Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","valueDensity":"NOT_DEFINED","vulnerabilityResponseEffort":"NOT_DEFINED","providerUrgency":"NOT_DEFINED","version":"4.0","baseSeverity":"MEDIUM","baseScore":6.9,"vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N"}},{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"HIGH","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"NONE","integrityImpact":"HIGH","availabilityImpact":"NONE","version":"3.1","baseSeverity":"MEDIUM","baseScore":4.9,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","lang":"en","description":"Incorrect Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-07-13T21:30:15.450Z"},"datePublic":"2026-06-30T00:00:00.000Z","cpeApplicability":[{"nodes":[{"operator":"OR","cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:*","versionStartIncluding":"2026.6.5","versionEndExcluding":"2026.6.9"}]}]}],"credits":[{"lang":"en","value":"Rex Liu (@rexpository)","type":"reporter"}],"x_generator":{"engine":"vulncheck-endgame"},"tags":["x_open-source"]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-15T14:26:03.434761Z","id":"CVE-2026-62193","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-15T14:26:14.293Z"}}]}}}