{"id":"CVE-2026-48172","state":"PUBLISHED","title":"LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of gre","description":"LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE \"cpanel_jsonapi_func=redisAble\" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7.","publishedAt":"2026-05-21T00:38:04.489Z","updatedAt":"2026-10-07T18:11:52.501Z","severity":{"score":10,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","source":"mitre"},"assigner":"mitre","products":["LiteSpeed Technologies cPanel Plugin","LiteSpeed Technologies WHM Plugin"],"affected":[{"vendor":"LiteSpeed Technologies","product":"cPanel Plugin","packageName":"WHM Plugin/cPanel Plugin","defaultStatus":"unaffected","versions":[{"version":"2.3","status":"affected","lessThan":"2.4.7","versionType":"custom"}],"collectionURL":"https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/download/","platforms":["Linux"]},{"vendor":"LiteSpeed Technologies","product":"WHM Plugin","packageName":"WHM Plugin/cPanel Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"5.3.1.0","versionType":"custom"}],"platforms":["Linux"]}],"references":["https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/cpanel","https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/release-log","https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/","https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-48172"],"weaknesses":["CWE-266"],"ingestedAt":"2026-10-29T20:12:07.131Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/48xxx/CVE-2026-48172.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-48172","state":"PUBLISHED","datePublished":"2026-05-21T00:38:04.489Z","dateUpdated":"2026-10-07T18:11:52.501Z","assignerShortName":"mitre","assignerOrgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateReserved":"2026-05-21T00:38:03.845Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE \"cpanel_jsonapi_func=redisAble\" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7."}],"affected":[{"vendor":"LiteSpeed Technologies","product":"cPanel Plugin","packageName":"WHM Plugin/cPanel Plugin","defaultStatus":"unaffected","versions":[{"version":"2.3","status":"affected","lessThan":"2.4.7","versionType":"custom"}],"collectionURL":"https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/download/","platforms":["Linux"]},{"vendor":"LiteSpeed Technologies","product":"WHM Plugin","packageName":"WHM Plugin/cPanel Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"5.3.1.0","versionType":"custom"}],"platforms":["Linux"]}],"references":[{"url":"https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/cpanel"},{"url":"https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/release-log"},{"url":"https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/"}],"metrics":[{"cvssV4_0":{"Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","Safety":"NOT_DEFINED","attackComplexity":"LOW","attackRequirements":"NONE","attackVector":"NETWORK","baseScore":10,"baseSeverity":"CRITICAL","privilegesRequired":"NONE","providerUrgency":"NOT_DEFINED","subAvailabilityImpact":"HIGH","subConfidentialityImpact":"HIGH","subIntegrityImpact":"HIGH","userInteraction":"NONE","valueDensity":"NOT_DEFINED","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0","vulnAvailabilityImpact":"HIGH","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnerabilityResponseEffort":"NOT_DEFINED"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-266","description":"CWE-266 Incorrect Privilege Assignment","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"mitre","orgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateUpdated":"2026-05-24T23:05:58.862Z"},"configurations":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Installation of the LiteSpeed cPanel PlugIn v2.3 or higher."}],"value":"Installation of the LiteSpeed cPanel PlugIn v2.3 or higher."}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Installation of LiteSpeed WHM PlugIn 5.3.1.0 and cPanel 2.4.7.&nbsp; Though installation of WHM 5.2.10 and cPanel 2.4.5 and above mitigate most of the issues."}],"value":"Installation of LiteSpeed WHM PlugIn 5.3.1.0 and cPanel 2.4.7.  Though installation of WHM 5.2.10 and cPanel 2.4.5 and above mitigate most of the issues."}],"tags":["x_known-exploited-vulnerability"],"x_generator":{"engine":"CVE-Request-form 0.0.1"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-48172","tags":["government-resource"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-27T03:55:25.936300Z","id":"CVE-2026-48172","options":[{"Exploitation":"active"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}},{"other":{"type":"kev","content":{"dateAdded":"2026-05-26","reference":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-48172"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-07T18:11:52.501Z"}}]}}}