{"id":"CVE-2026-4410","state":"PUBLISHED","title":"IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by a denial of service","description":"IBM WebSphere Application Server - Liberty 19.0.0.7 through 26.0.0.5 and IBM WebSphere Application Server 9.0, and 8.5 and WebSphere Application Server Liberty are vulnerable to a denial of service, caused by sending a specially-crafted request. A remote attacker could exploit this vulnerability to cause the server to consume memory resources.","publishedAt":"2026-05-27T12:54:48.488Z","updatedAt":"2026-05-27T15:25:09.833Z","severity":{"score":4.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server - Liberty","IBM WebSphere Application Server"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"19.0.0.7","status":"affected","lessThanOrEqual":"26.0.0.5","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server___liberty:19.0.0.7:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server___liberty:26.0.0.5:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server","versions":[{"version":"9.0","status":"affected"},{"version":"8.5","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:8.5.0:*:*:*:*:*:*:*"]}],"references":["https://www.ibm.com/support/pages/node/7273424"],"weaknesses":["CWE-400"],"ingestedAt":"2026-10-29T20:12:16.098Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/4xxx/CVE-2026-4410.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-4410","state":"PUBLISHED","datePublished":"2026-05-27T12:54:48.488Z","dateUpdated":"2026-05-27T15:25:09.833Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2026-03-19T02:14:15.887Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by a denial of service","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server - Liberty 19.0.0.7 through 26.0.0.5 and IBM WebSphere Application Server 9.0, and 8.5 and WebSphere Application Server Liberty are vulnerable to a denial of service, caused by sending a specially-crafted request. A remote attacker could exploit this vulnerability to cause the server to consume memory resources."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"19.0.0.7","status":"affected","lessThanOrEqual":"26.0.0.5","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server___liberty:19.0.0.7:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server___liberty:26.0.0.5:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server","versions":[{"version":"9.0","status":"affected"},{"version":"8.5","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:8.5.0:*:*:*:*:*:*:*"]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7273424","tags":["vendor-advisory","patch"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"ADJACENT_NETWORK","attackComplexity":"HIGH","privilegesRequired":"LOW","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"NONE","integrityImpact":"NONE","availabilityImpact":"HIGH","baseSeverity":"MEDIUM","baseScore":4.8,"vectorString":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H"}}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2026-05-27T12:54:48.488Z"},"solutions":[{"lang":"en","value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH70807 and APAR PH70616. To determine if a feature is enabled for WebSphere Application Server Liberty, refer to  How to determine if Liberty is using a specific feature https://www.ibm.com/support/pages/node/6553910 . \n\n\n\nFor IBM WebSphere Application Server Liberty 19.0.0.7 - 26.0.0.5 using the sipServlet-1.1 feature:\n\n\n\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  PH70807 https://www.ibm.com/support/pages/node/7273237 \n--OR--\n· Apply Fix Pack 26.0.0.6 or later (targeted availability 2Q2026).\n\n\n\n\n\nFor IBM WebSphere Application Server traditional:\n\n\n\nFor V9.0.0.0 through 9.0.5.27:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  PH70616 https://www.ibm.com/support/pages/node/7269402 \n--OR--\n· Apply Fix Pack 9.0.5.28 or later (targeted availability 2Q2026).  \n\n\n\nFor V8.5.0.0 through 8.5.5.29:\n· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves  PH70616 https://www.ibm.com/support/pages/node/7269402 \n--OR--\n· Apply Fix Pack 8.5.5.30 or later (targeted availability 3Q2026).\n\n\n\n\n\n\n\nAdditional interim fixes may be available and linked off the interim fix download page.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH70807 and APAR PH70616. To determine if a feature is enabled for WebSphere Application Server Liberty, refer to <a href=\"https://www.ibm.com/support/pages/node/6553910\" rel=\"nofollow\">How to determine if Liberty is using a specific feature</a>.&nbsp;</p><div><p><strong>For IBM WebSphere Application Server Liberty 19.0.0.7 - 26.0.0.5 using the sipServlet-1.1 feature:</strong></p><p>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7273237\" rel=\"nofollow\">PH70807</a><br>--OR--<br>· Apply Fix Pack 26.0.0.6 or later (targeted availability 2Q2026).</p></div><p><strong>For IBM WebSphere Application Server traditional:</strong></p><p><strong>For V9.0.0.0 through 9.0.5.27:</strong><br>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7269402\" rel=\"nofollow\">PH70616</a><br>--OR--<br>· Apply Fix Pack 9.0.5.28 or later (targeted availability 2Q2026).&nbsp;&nbsp;</p><p><strong>For V8.5.0.0 through 8.5.5.29:</strong><br>· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7269402\" rel=\"nofollow\">PH70616</a><br>--OR--<br>· Apply Fix Pack 8.5.5.30 or later (targeted availability 3Q2026).</p><p></p><p>Additional interim fixes may be available and linked off the interim fix download page.</p>"}]}],"x_generator":{"engine":"ibm-cvegen"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-27T15:24:44.817386Z","id":"CVE-2026-4410","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-400","type":"CWE","lang":"en","description":"CWE-400 Uncontrolled Resource Consumption"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-05-27T15:25:09.833Z"}}]}}}