{"id":"CVE-2026-4245","state":"PUBLISHED","title":"Post Duplicator <= 3.0.11 - Authorization Bypass to Authenticated (Contributor+) Post Duplication","description":"The Post Duplicator plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.0.11. This is due to the `duplicate_post_permissions()` permission callback only verifying the `duplicate_posts` capability without checking whether the requesting user holds `publish_posts` or other status-gated capabilities. This makes it possible for authenticated attackers, with Contributor-level access and above, to create duplicate posts with `future` (scheduled, auto-publishes) or `private` status, bypassing editorial review. Additionally, the REST endpoint does not enforce administrator-configured post-type duplication restrictions, allowing duplication of post types that have been explicitly disabled.","publishedAt":"2026-08-22T11:30:40.062Z","updatedAt":"2026-08-24T20:01:34.600Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["metaphorcreations Post Duplicator"],"affected":[{"vendor":"metaphorcreations","product":"Post Duplicator","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.0.11","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/bb671c8f-9e14-4f79-adfa-72f48ec02449?source=cve","https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L520","https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L635","https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L740","https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L624","https://plugins.trac.wordpress.org/changeset/3485579/"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T20:12:16.098Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/4xxx/CVE-2026-4245.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-4245","state":"PUBLISHED","datePublished":"2026-08-22T11:30:40.062Z","dateUpdated":"2026-08-24T20:01:34.600Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-03-15T21:44:14.805Z"},"containers":{"cna":{"title":"Post Duplicator <= 3.0.11 - Authorization Bypass to Authenticated (Contributor+) Post Duplication","descriptions":[{"lang":"en","value":"The Post Duplicator plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.0.11. This is due to the `duplicate_post_permissions()` permission callback only verifying the `duplicate_posts` capability without checking whether the requesting user holds `publish_posts` or other status-gated capabilities. This makes it possible for authenticated attackers, with Contributor-level access and above, to create duplicate posts with `future` (scheduled, auto-publishes) or `private` status, bypassing editorial review. Additionally, the REST endpoint does not enforce administrator-configured post-type duplication restrictions, allowing duplication of post types that have been explicitly disabled."}],"affected":[{"vendor":"metaphorcreations","product":"Post Duplicator","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.0.11","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/bb671c8f-9e14-4f79-adfa-72f48ec02449?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L520"},{"url":"https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L635"},{"url":"https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L740"},{"url":"https://plugins.trac.wordpress.org/browser/post-duplicator/trunk/includes/api.php#L624"},{"url":"https://plugins.trac.wordpress.org/changeset/3485579/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","lang":"en","description":"CWE-863 Incorrect Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-08-22T11:30:40.062Z"},"credits":[{"lang":"en","type":"finder","value":"Quốc Huy (jtwings)"}],"timeline":[{"time":"2026-03-15T22:02:45.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-08-21T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-08-24T20:01:25.244331Z","id":"CVE-2026-4245","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-08-24T20:01:34.600Z"}}]}}}