{"id":"CVE-2026-42155","state":"PUBLISHED","title":"Magento LTS: Weak API Session ID — Predictable MD5 of Time-Derived Inputs","description":"Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, the XML-RPC / SOAP API session ID is generated using an outdated, time-based construction rather than a Cryptographically Secure Pseudo-Random Number Generator (CSPRNG). All inputs to the MD5 hash are time-derived and non-secure. Because the resulting digest relies entirely on the timestamp and the PHP internal LCG state, the effective entropy is severely constrained. This violates the OWASP ASVS v4 requirement of ≥ 64 bits of entropy (V3.2.2) and NIST SP 800-63B standards. By narrowing the LCG window (via server state leaks or general predictability) and leveraging the lack of API rate-limiting, an attacker can generate a localized pool of candidate MD5 hashes and execute a high-speed online brute-force attack to hijack active API sessions. This vulnerability is fixed in 20.18.0.","publishedAt":"2026-05-15T17:05:02.436Z","updatedAt":"2026-05-15T17:36:27.793Z","severity":{"score":9.3,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["OpenMage magento-lts"],"affected":[{"vendor":"OpenMage","product":"magento-lts","versions":[{"version":"< 20.18.0","status":"affected"}]}],"references":["https://github.com/OpenMage/magento-lts/security/advisories/GHSA-2cwr-gcf9-pvxr"],"weaknesses":["CWE-330","CWE-331","CWE-338"],"ingestedAt":"2026-10-29T20:11:57.932Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/42xxx/CVE-2026-42155.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-42155","state":"PUBLISHED","datePublished":"2026-05-15T17:05:02.436Z","dateUpdated":"2026-05-15T17:36:27.793Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2026-04-24T17:15:21.835Z"},"containers":{"cna":{"title":"Magento LTS: Weak API Session ID — Predictable MD5 of Time-Derived Inputs","descriptions":[{"lang":"en","value":"Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, the XML-RPC / SOAP API session ID is generated using an outdated, time-based construction rather than a Cryptographically Secure Pseudo-Random Number Generator (CSPRNG). All inputs to the MD5 hash are time-derived and non-secure. Because the resulting digest relies entirely on the timestamp and the PHP internal LCG state, the effective entropy is severely constrained. This violates the OWASP ASVS v4 requirement of ≥ 64 bits of entropy (V3.2.2) and NIST SP 800-63B standards. By narrowing the LCG window (via server state leaks or general predictability) and leveraging the lack of API rate-limiting, an attacker can generate a localized pool of candidate MD5 hashes and execute a high-speed online brute-force attack to hijack active API sessions. This vulnerability is fixed in 20.18.0."}],"affected":[{"vendor":"OpenMage","product":"magento-lts","versions":[{"version":"< 20.18.0","status":"affected"}]}],"references":[{"url":"https://github.com/OpenMage/magento-lts/security/advisories/GHSA-2cwr-gcf9-pvxr","name":"https://github.com/OpenMage/magento-lts/security/advisories/GHSA-2cwr-gcf9-pvxr","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"LOW","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":9.3,"baseSeverity":"CRITICAL","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-330","lang":"en","description":"CWE-330: Use of Insufficiently Random Values","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-331","lang":"en","description":"CWE-331: Insufficient Entropy","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-338","lang":"en","description":"CWE-338: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-05-15T17:05:02.436Z"},"source":{"advisory":"GHSA-2cwr-gcf9-pvxr","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://github.com/OpenMage/magento-lts/security/advisories/GHSA-2cwr-gcf9-pvxr","tags":["exploit"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-15T17:36:24.561394Z","id":"CVE-2026-42155","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-05-15T17:36:27.793Z"}}]}}}