{"id":"CVE-2026-41386","state":"PUBLISHED","title":"OpenClaw < 2026.3.22 - Privilege Escalation via Unbound Bootstrap Setup Codes","description":"OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles and scopes during pairing. Attackers can exploit this during first-use device pairing to escalate privileges beyond their intended role and scope.","publishedAt":"2026-04-28T18:09:48.856Z","updatedAt":"2026-04-29T12:49:41.640Z","severity":{"score":9.1,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["OpenClaw OpenClaw"],"affected":[{"vendor":"OpenClaw","product":"OpenClaw","packageURL":"pkg:npm/openclaw","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2026.3.22","versionType":"semver"},{"version":"2026.3.22","status":"unaffected","versionType":"semver"}]}],"references":["https://github.com/openclaw/openclaw/security/advisories/GHSA-gg9v-mgcp-v6m7","https://github.com/openclaw/openclaw/commit/a600c72ed7d0045a27f58bf031d2b36ecb0141c9","https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-unbound-bootstrap-setup-codes"],"weaknesses":["CWE-648"],"ingestedAt":"2026-10-29T20:11:57.932Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/41xxx/CVE-2026-41386.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-41386","state":"PUBLISHED","datePublished":"2026-04-28T18:09:48.856Z","dateUpdated":"2026-04-29T12:49:41.640Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-04-20T14:12:09.519Z"},"containers":{"cna":{"title":"OpenClaw < 2026.3.22 - Privilege Escalation via Unbound Bootstrap Setup Codes","descriptions":[{"lang":"en","value":"OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles and scopes during pairing. Attackers can exploit this during first-use device pairing to escalate privileges beyond their intended role and scope."}],"affected":[{"vendor":"OpenClaw","product":"OpenClaw","packageURL":"pkg:npm/openclaw","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2026.3.22","versionType":"semver"},{"version":"2026.3.22","status":"unaffected","versionType":"semver"}]}],"references":[{"url":"https://github.com/openclaw/openclaw/security/advisories/GHSA-gg9v-mgcp-v6m7","name":"GitHub Security Advisory (GHSA-gg9v-mgcp-v6m7)","tags":["vendor-advisory"]},{"url":"https://github.com/openclaw/openclaw/commit/a600c72ed7d0045a27f58bf031d2b36ecb0141c9","name":"Patch Commit","tags":["patch"]},{"url":"https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-unbound-bootstrap-setup-codes","name":"VulnCheck Advisory: OpenClaw < 2026.3.22 - Privilege Escalation via Unbound Bootstrap Setup Codes","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"PRESENT","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","subConfidentialityImpact":"NONE","vulnIntegrityImpact":"HIGH","subIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subAvailabilityImpact":"NONE","exploitMaturity":"NOT_DEFINED","Safety":"NOT_DEFINED","Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","valueDensity":"NOT_DEFINED","vulnerabilityResponseEffort":"NOT_DEFINED","providerUrgency":"NOT_DEFINED","version":"4.0","baseSeverity":"CRITICAL","baseScore":9.1,"vectorString":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N"}},{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"NONE","version":"3.1","baseSeverity":"CRITICAL","baseScore":9.1,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-648","lang":"en","description":"CWE-648: Incorrect Use of Privileged APIs","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-04-28T18:09:48.856Z"},"tags":["x_open-source"],"datePublic":"2026-03-31T00:00:00.000Z","cpeApplicability":[{"nodes":[{"operator":"OR","cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:*","versionEndExcluding":"2026.3.22"}]}]}],"credits":[{"lang":"en","value":"tdjackey","type":"reporter"}],"x_generator":{"engine":"vulncheck"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-04-29T12:48:41.582369Z","id":"CVE-2026-41386","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-04-29T12:49:41.640Z"}}]}}}