{"id":"CVE-2026-4059","state":"PUBLISHED","title":"ShopLentor <= 3.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'button_text' Shortcode Attribute","description":"The ShopLentor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the woolentor_quickview_button shortcode's button_text attribute in all versions up to, and including, 3.3.5. This is due to insufficient input sanitization and missing output escaping on user-supplied shortcode attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2026-04-14T03:37:33.893Z","updatedAt":"2026-04-14T14:04:52.486Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin"],"affected":[{"vendor":"devitemsllc","product":"ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.3.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/fdf0b13e-154c-4007-bfc2-5346d906f7ca?source=cve","https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/3.3.4/includes/modules/quickview/includes/classes/Frontend/Shortcode.php#L61","https://plugins.trac.wordpress.org/browser/woolentor-addons/trunk/includes/modules/quickview/includes/classes/Frontend/Shortcode.php#L61","https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/3.3.4/includes/modules/quickview/includes/templates/quickview-button.php#L1","https://ti.wordfence.io/vendors/patch/1796/download","https://plugins.trac.wordpress.org/changeset/3493664/woolentor-addons/trunk/includes/modules/quickview/includes/classes/Frontend/Shortcode.php","https://plugins.trac.wordpress.org/changeset?old_path=%2Fwoolentor-addons/tags/3.3.5&new_path=%2Fwoolentor-addons/tags/3.3.6"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:12:16.098Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/4xxx/CVE-2026-4059.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-4059","state":"PUBLISHED","datePublished":"2026-04-14T03:37:33.893Z","dateUpdated":"2026-04-14T14:04:52.486Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-03-12T17:15:49.497Z"},"containers":{"cna":{"title":"ShopLentor <= 3.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'button_text' Shortcode Attribute","descriptions":[{"lang":"en","value":"The ShopLentor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the woolentor_quickview_button shortcode's button_text attribute in all versions up to, and including, 3.3.5. This is due to insufficient input sanitization and missing output escaping on user-supplied shortcode attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"devitemsllc","product":"ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.3.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/fdf0b13e-154c-4007-bfc2-5346d906f7ca?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/3.3.4/includes/modules/quickview/includes/classes/Frontend/Shortcode.php#L61"},{"url":"https://plugins.trac.wordpress.org/browser/woolentor-addons/trunk/includes/modules/quickview/includes/classes/Frontend/Shortcode.php#L61"},{"url":"https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/3.3.4/includes/modules/quickview/includes/templates/quickview-button.php#L1"},{"url":"https://ti.wordfence.io/vendors/patch/1796/download"},{"url":"https://plugins.trac.wordpress.org/changeset/3493664/woolentor-addons/trunk/includes/modules/quickview/includes/classes/Frontend/Shortcode.php"},{"url":"https://plugins.trac.wordpress.org/changeset?old_path=%2Fwoolentor-addons/tags/3.3.5&new_path=%2Fwoolentor-addons/tags/3.3.6"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-14T03:37:33.893Z"},"credits":[{"lang":"en","type":"finder","value":"Djaidja Moundjid"}],"timeline":[{"time":"2026-03-12T17:31:14.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-04-13T14:48:10.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2026-4059","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2026-04-14T14:02:11.467462Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-04-14T14:04:52.486Z"}}]}}}