{"id":"CVE-2026-33074","state":"PUBLISHED","title":"Discourse: Vulnerability in discourse-subscriptions plugin allowing users to self-grant to higher tier subscriptions","description":"Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, a user may be able to purchase a lower tier subscription but grant themselves the benefits that comes along with a higher tier subscription. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.","publishedAt":"2026-03-31T17:41:32.012Z","updatedAt":"2026-03-31T18:52:20.144Z","severity":{"score":6.3,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["discourse discourse"],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":">= 2026.1.0-latest, < 2026.1.3","status":"affected"},{"version":">= 2026.2.0-latest, < 2026.2.2","status":"affected"},{"version":">= 2026.3.0-latest, < 2026.3.0","status":"affected"}]}],"references":["https://github.com/discourse/discourse/security/advisories/GHSA-9vg5-mp49-xghh","https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80"],"weaknesses":["CWE-269","CWE-285"],"ingestedAt":"2026-10-29T20:11:40.391Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/33xxx/CVE-2026-33074.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-33074","state":"PUBLISHED","datePublished":"2026-03-31T17:41:32.012Z","dateUpdated":"2026-03-31T18:52:20.144Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2026-03-17T19:27:06.344Z"},"containers":{"cna":{"title":"Discourse: Vulnerability in discourse-subscriptions plugin allowing users to self-grant to higher tier subscriptions","descriptions":[{"lang":"en","value":"Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, a user may be able to purchase a lower tier subscription but grant themselves the benefits that comes along with a higher tier subscription. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0."}],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":">= 2026.1.0-latest, < 2026.1.3","status":"affected"},{"version":">= 2026.2.0-latest, < 2026.2.2","status":"affected"},{"version":">= 2026.3.0-latest, < 2026.3.0","status":"affected"}]}],"references":[{"url":"https://github.com/discourse/discourse/security/advisories/GHSA-9vg5-mp49-xghh","name":"https://github.com/discourse/discourse/security/advisories/GHSA-9vg5-mp49-xghh","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80","name":"https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"HIGH","attackRequirements":"PRESENT","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"LOW","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":6.3,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-269","lang":"en","description":"CWE-269: Improper Privilege Management","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-285","lang":"en","description":"CWE-285: Improper Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-03-31T17:41:32.012Z"},"source":{"advisory":"GHSA-9vg5-mp49-xghh","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-03-31T18:50:09.413946Z","id":"CVE-2026-33074","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-03-31T18:52:20.144Z"}}]}}}