{"id":"CVE-2026-32944","state":"PUBLISHED","title":"Parse Server crash via deeply nested query condition operators","description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.21 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0-alpha.21 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available.","publishedAt":"2026-03-18T21:50:08.390Z","updatedAt":"2026-03-19T16:56:38.160Z","severity":{"score":8.7,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["parse-community parse-server"],"affected":[{"vendor":"parse-community","product":"parse-server","versions":[{"version":">= 9.0.0, < 9.6.0-alpha.21","status":"affected"},{"version":"< 8.6.45","status":"affected"}]}],"references":["https://github.com/parse-community/parse-server/security/advisories/GHSA-9xp9-j92r-p88v","https://github.com/parse-community/parse-server/pull/10202","https://github.com/parse-community/parse-server/pull/10203"],"weaknesses":["CWE-674"],"ingestedAt":"2026-10-29T20:11:40.391Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/32xxx/CVE-2026-32944.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-32944","state":"PUBLISHED","datePublished":"2026-03-18T21:50:08.390Z","dateUpdated":"2026-03-19T16:56:38.160Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2026-03-17T00:05:53.283Z"},"containers":{"cna":{"title":"Parse Server crash via deeply nested query condition operators","descriptions":[{"lang":"en","value":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.21 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0-alpha.21 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available."}],"affected":[{"vendor":"parse-community","product":"parse-server","versions":[{"version":">= 9.0.0, < 9.6.0-alpha.21","status":"affected"},{"version":"< 8.6.45","status":"affected"}]}],"references":[{"url":"https://github.com/parse-community/parse-server/security/advisories/GHSA-9xp9-j92r-p88v","name":"https://github.com/parse-community/parse-server/security/advisories/GHSA-9xp9-j92r-p88v","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/parse-community/parse-server/pull/10202","name":"https://github.com/parse-community/parse-server/pull/10202","tags":["x_refsource_MISC"]},{"url":"https://github.com/parse-community/parse-server/pull/10203","name":"https://github.com/parse-community/parse-server/pull/10203","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":8.7,"baseSeverity":"HIGH","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-674","lang":"en","description":"CWE-674: Uncontrolled Recursion","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-03-18T21:50:08.390Z"},"source":{"advisory":"GHSA-9xp9-j92r-p88v","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-03-19T16:56:21.057916Z","id":"CVE-2026-32944","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-03-19T16:56:38.160Z"}}]}}}