{"id":"CVE-2026-2988","state":"PUBLISHED","title":"Blubrry PowerPress <= 11.15.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via powerpress and podcast Shortcodes","description":"The Blubrry PowerPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'powerpress' and 'podcast' shortcodes in versions up to, and including, 11.15.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2026-04-08T02:25:40.994Z","updatedAt":"2026-04-08T17:28:15.802Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["blubrry PowerPress Podcasting plugin by Blubrry"],"affected":[{"vendor":"blubrry","product":"PowerPress Podcasting plugin by Blubrry","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"11.15.15","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/de25459d-9e19-4e3e-982f-0b34fa89dc30?source=cve","https://plugins.trac.wordpress.org/changeset/3473781/powerpress"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:11:31.369Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/2xxx/CVE-2026-2988.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-2988","state":"PUBLISHED","datePublished":"2026-04-08T02:25:40.994Z","dateUpdated":"2026-04-08T17:28:15.802Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-02-22T19:41:30.680Z"},"containers":{"cna":{"title":"Blubrry PowerPress <= 11.15.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via powerpress and podcast Shortcodes","descriptions":[{"lang":"en","value":"The Blubrry PowerPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'powerpress' and 'podcast' shortcodes in versions up to, and including, 11.15.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"blubrry","product":"PowerPress Podcasting plugin by Blubrry","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"11.15.15","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/de25459d-9e19-4e3e-982f-0b34fa89dc30?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3473781/powerpress"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:28:15.802Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Yudha - DJ"}],"timeline":[{"time":"2026-02-25T19:37:25.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-04-07T13:33:12.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-04-08T14:47:25.742606Z","id":"CVE-2026-2988","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-04-08T16:14:16.034Z"}}]}}}