{"id":"CVE-2026-2951","state":"PUBLISHED","title":"Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor <= 3.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gutentor Block HTML","description":"The Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 3.5.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2026-04-23T02:25:21.258Z","updatedAt":"2026-04-23T12:51:56.328Z","severity":{"score":5.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["gutentor Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor"],"affected":[{"vendor":"gutentor","product":"Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.5.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/d7c639b8-35f5-4eaf-a663-1adab3ba2a16?source=cve","https://plugins.trac.wordpress.org/changeset/3495930/gutentor"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:11:31.369Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/2xxx/CVE-2026-2951.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-2951","state":"PUBLISHED","datePublished":"2026-04-23T02:25:21.258Z","dateUpdated":"2026-04-23T12:51:56.328Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-02-21T20:23:25.224Z"},"containers":{"cna":{"title":"Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor <= 3.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gutentor Block HTML","descriptions":[{"lang":"en","value":"The Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 3.5.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"gutentor","product":"Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.5.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/d7c639b8-35f5-4eaf-a663-1adab3ba2a16?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3495930/gutentor"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","baseScore":5.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-23T02:25:21.258Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Yudha - DJ"}],"timeline":[{"time":"2026-04-22T13:44:42.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-04-23T12:49:27.084318Z","id":"CVE-2026-2951","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-04-23T12:51:56.328Z"}}]}}}