{"id":"CVE-2026-2498","state":"PUBLISHED","title":"WP Social Meta <= 1.0.1 - Authenticated (Administrator+) Stored Cross-Site Scripting via Settings","description":"The WP Social Meta plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.","publishedAt":"2026-02-26T01:24:14.553Z","updatedAt":"2026-04-08T16:45:03.304Z","severity":{"score":4.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["bulktheme WP Social Meta"],"affected":[{"vendor":"bulktheme","product":"WP Social Meta","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/313906d3-3999-4255-b9ac-580d9d3e80e6?source=cve","https://plugins.trac.wordpress.org/browser/wp-social-meta/trunk/wpsm.php#L205","https://plugins.trac.wordpress.org/browser/wp-social-meta/tags/1.0.1/wpsm.php#L205","https://plugins.trac.wordpress.org/browser/wp-social-meta/trunk/wpsm.php#L158","https://plugins.trac.wordpress.org/browser/wp-social-meta/tags/1.0.1/wpsm.php#L158"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:11:31.369Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/2xxx/CVE-2026-2498.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-2498","state":"PUBLISHED","datePublished":"2026-02-26T01:24:14.553Z","dateUpdated":"2026-04-08T16:45:03.304Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-02-13T21:38:03.610Z"},"containers":{"cna":{"title":"WP Social Meta <= 1.0.1 - Authenticated (Administrator+) Stored Cross-Site Scripting via Settings","descriptions":[{"lang":"en","value":"The WP Social Meta plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled."}],"affected":[{"vendor":"bulktheme","product":"WP Social Meta","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/313906d3-3999-4255-b9ac-580d9d3e80e6?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-social-meta/trunk/wpsm.php#L205"},{"url":"https://plugins.trac.wordpress.org/browser/wp-social-meta/tags/1.0.1/wpsm.php#L205"},{"url":"https://plugins.trac.wordpress.org/browser/wp-social-meta/trunk/wpsm.php#L158"},{"url":"https://plugins.trac.wordpress.org/browser/wp-social-meta/tags/1.0.1/wpsm.php#L158"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":4.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:45:03.304Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Nur Ibnu Hubab"}],"timeline":[{"time":"2026-02-25T12:49:58.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-02-26T15:29:27.979556Z","id":"CVE-2026-2498","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-02-26T15:29:44.068Z"}}]}}}