{"id":"CVE-2026-24851","state":"PUBLISHED","title":"OpenFGA Improper Policy Enforcement","description":"OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22<= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed. The vulnerability requires a model that has a a relation directly assignable by a type bound public access and assignable by type bound non-public access, a tuple assigned for the relation that is a type bound public access, a tuple assigned for the same object with the same relation that is not type bound public access, and a tuple assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access. This vulnerability is fixed in v1.11.3.","publishedAt":"2026-02-06T17:51:27.274Z","updatedAt":"2026-02-06T18:47:21.029Z","severity":{"score":5.8,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["openfga openfga"],"affected":[{"vendor":"openfga","product":"openfga","versions":[{"version":"< 1.11.3","status":"affected"}]}],"references":["https://github.com/openfga/openfga/security/advisories/GHSA-jq9f-gm9w-rwm9","https://github.com/openfga/openfga/releases/tag/v1.11.3"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T20:11:21.040Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/24xxx/CVE-2026-24851.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-24851","state":"PUBLISHED","datePublished":"2026-02-06T17:51:27.274Z","dateUpdated":"2026-02-06T18:47:21.029Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2026-01-27T14:51:03.060Z"},"containers":{"cna":{"title":"OpenFGA Improper Policy Enforcement","descriptions":[{"lang":"en","value":"OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22<= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed. The vulnerability requires a model that has a a relation directly assignable by a type bound public access and assignable by type bound non-public access, a tuple assigned for the relation that is a type bound public access, a tuple assigned for the same object with the same relation that is not type bound public access, and a tuple assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access. This vulnerability is fixed in v1.11.3."}],"affected":[{"vendor":"openfga","product":"openfga","versions":[{"version":"< 1.11.3","status":"affected"}]}],"references":[{"url":"https://github.com/openfga/openfga/security/advisories/GHSA-jq9f-gm9w-rwm9","name":"https://github.com/openfga/openfga/security/advisories/GHSA-jq9f-gm9w-rwm9","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/openfga/openfga/releases/tag/v1.11.3","name":"https://github.com/openfga/openfga/releases/tag/v1.11.3","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"PRESENT","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"HIGH","subIntegrityImpact":"HIGH","subAvailabilityImpact":"HIGH","baseScore":5.8,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","lang":"en","description":"CWE-863: Incorrect Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-02-06T17:51:27.274Z"},"source":{"advisory":"GHSA-jq9f-gm9w-rwm9","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-02-06T18:47:12.440780Z","id":"CVE-2026-24851","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-02-06T18:47:21.029Z"}}]}}}