{"id":"CVE-2026-2482","state":"PUBLISHED","title":"IBM WebSphere Application Server Liberty is affected by a cross-site request forgery","description":"IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 is vulnerable to cross-site request forgery which could allow an attacker to execute malicious and unauthorized actions transmitted from a user that the website trusts.","publishedAt":"2026-07-29T18:19:36.707Z","updatedAt":"2026-07-30T15:19:30.028Z","severity":{"score":3.1,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server - Liberty"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.8","versionType":"semver"}]}],"references":["https://www.ibm.com/support/pages/node/7281651"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:11:31.369Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/2xxx/CVE-2026-2482.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-2482","state":"PUBLISHED","datePublished":"2026-07-29T18:19:36.707Z","dateUpdated":"2026-07-30T15:19:30.028Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2026-02-13T18:39:00.390Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server Liberty is affected by a cross-site request forgery","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 is vulnerable to cross-site request forgery which could allow an attacker to execute malicious and unauthorized actions transmitted from a user that the website trusts."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.8","versionType":"semver"}]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7281651","tags":["vendor-advisory","patch"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"HIGH","privilegesRequired":"NONE","userInteraction":"REQUIRED","scope":"UNCHANGED","confidentialityImpact":"NONE","integrityImpact":"LOW","availabilityImpact":"NONE","baseSeverity":"LOW","baseScore":3.1,"vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2026-07-29T18:19:36.707Z"},"solutions":[{"lang":"en","value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH71678. To determine if a feature is enabled for IBM WebSphere Application Server Liberty, refer to  How to determine if Liberty is using a specific feature https://www.ibm.com/support/pages/node/6553910 . \n\nFor IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8 using the collectiveController-1.0 feature(s): \n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  PH71678  https://www.ibm.com/support/pages/node/7281098 \n--OR--\n· Apply Liberty Fix Pack 26.0.0.9 or later (targeted availability 3Q2026). \n\nAdditional interim fixes may be available and linked off the interim fix download page.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH71678. To determine if a feature is enabled for IBM WebSphere Application Server Liberty, refer to <a href=\"https://www.ibm.com/support/pages/node/6553910\" rel=\"nofollow\">How to determine if Liberty is using a specific feature</a>. <br/><br/><strong>For IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8 using the collectiveController-1.0 feature(s): </strong><br/>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7281098?1\" rel=\"nofollow\">PH71678 </a><br/>--OR--<br/>· Apply Liberty Fix Pack 26.0.0.9 or later (targeted availability 3Q2026). <br/><br/>Additional interim fixes may be available and linked off the interim fix download page.</p>"}]}],"x_generator":{"engine":"ibm-cvegen"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-30T13:55:25.364194Z","id":"CVE-2026-2482","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-30T15:19:30.028Z"}}]}}}