{"id":"CVE-2026-18499","state":"PUBLISHED","title":"IBM WebSphere Application Server Liberty is affected by a privilege escalation","description":"IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 is vulnerable to a privilege escalation when using Liberty collectives.","publishedAt":"2026-08-12T16:25:07.006Z","updatedAt":"2026-08-13T03:55:46.982Z","severity":{"score":8.1,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server - Liberty"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.8","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server_liberty:17.0.0.3:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server_liberty:26.0.0.8:*:*:*:*:*:*:*"]}],"references":["https://www.ibm.com/support/pages/node/7283489"],"weaknesses":["CWE-285"],"ingestedAt":"2026-10-29T20:11:10.572Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/18xxx/CVE-2026-18499.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-18499","state":"PUBLISHED","datePublished":"2026-08-12T16:25:07.006Z","dateUpdated":"2026-08-13T03:55:46.982Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2026-07-31T16:05:24.890Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server Liberty is affected by a privilege escalation","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 is vulnerable to a privilege escalation when using Liberty collectives."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.8","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server_liberty:17.0.0.3:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server_liberty:26.0.0.8:*:*:*:*:*:*:*"]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7283489","tags":["vendor-advisory","patch"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"LOW","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"NONE","baseSeverity":"HIGH","baseScore":8.1,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","lang":"en","description":"CWE-285 Improper Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2026-08-12T16:25:07.006Z"},"solutions":[{"lang":"en","value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR DT497580. To determine if a feature is enabled for IBM WebSphere Application Server Liberty, refer to  How to determine if Liberty is using a specific feature https://www.ibm.com/support/pages/node/6553910 . \n\nFor IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8 using the collectiveController-1.0 or collectiveMember-1.0 feature(s): \n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  DT497580 https://www.ibm.com/support/pages/node/7283466 \n--OR--\n· Apply Liberty Fix Pack 26.0.0.9 or later (targeted availability 3Q2026). \n\nAdditional interim fixes may be available and linked off the interim fix download page.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR DT497580. To determine if a feature is enabled for IBM WebSphere Application Server Liberty, refer to <a href=\"https://www.ibm.com/support/pages/node/6553910\" rel=\"nofollow\">How to determine if Liberty is using a specific feature</a>. <br/><br/><strong>For IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8 using the collectiveController-1.0 or collectiveMember-1.0 feature(s): </strong><br/>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7283466\" rel=\"nofollow\">DT497580</a><br/>--OR--<br/>· Apply Liberty Fix Pack 26.0.0.9 or later (targeted availability 3Q2026). <br/><br/>Additional interim fixes may be available and linked off the interim fix download page.</p>"}]}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-08-12T00:00:00+00:00","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3","id":"CVE-2026-18499"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-08-13T03:55:46.982Z"}}]}}}