{"id":"CVE-2026-1829","state":"PUBLISHED","title":"Content Visibility for Divi Builder <= 4.02 - Authenticated (Contributor+) Remote Code Execution","description":"The Content Visibility for Divi Builder plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.02 via the 'et_pb_text' shortcode 'cvdb_content_visibility_check' parameter. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.","publishedAt":"2026-06-02T17:28:25.213Z","updatedAt":"2026-06-03T15:12:07.576Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["jhorowitz Content Visibility for Divi Builder"],"affected":[{"vendor":"jhorowitz","product":"Content Visibility for Divi Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.02","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/2ea89c44-8ed0-4ab7-a049-4d1b03a898c7?source=cve","https://plugins.trac.wordpress.org/browser/content-visibility-for-divi-builder/tags/4.01/includes/plugin.class.php#L229","https://plugins.trac.wordpress.org/changeset/3543621/content-visibility-for-divi-builder"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:11:10.572Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/1xxx/CVE-2026-1829.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-1829","state":"PUBLISHED","datePublished":"2026-06-02T17:28:25.213Z","dateUpdated":"2026-06-03T15:12:07.576Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-02-03T14:31:46.015Z"},"containers":{"cna":{"title":"Content Visibility for Divi Builder <= 4.02 - Authenticated (Contributor+) Remote Code Execution","descriptions":[{"lang":"en","value":"The Content Visibility for Divi Builder plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.02 via the 'et_pb_text' shortcode 'cvdb_content_visibility_check' parameter. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server."}],"affected":[{"vendor":"jhorowitz","product":"Content Visibility for Divi Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.02","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/2ea89c44-8ed0-4ab7-a049-4d1b03a898c7?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/content-visibility-for-divi-builder/tags/4.01/includes/plugin.class.php#L229"},{"url":"https://plugins.trac.wordpress.org/changeset/3543621/content-visibility-for-divi-builder"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-06-02T17:28:25.213Z"},"credits":[{"lang":"en","type":"finder","value":"ZAST.AI"}],"timeline":[{"time":"2026-02-03T19:26:29.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-06-02T05:02:06.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-06-03T15:11:56.891761Z","id":"CVE-2026-1829","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-06-03T15:12:07.576Z"}}]}}}