{"id":"CVE-2026-1826","state":"PUBLISHED","title":"OpenPOS Lite <= 3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes","description":"The OpenPOS Lite – Point of Sale for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'width' parameter of the order_qrcode shortcode in all versions up to, and including, 3.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2026-02-11T08:26:27.919Z","updatedAt":"2026-04-08T17:29:27.754Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["openpos OpenPOS Lite – Point of Sale for WooCommerce"],"affected":[{"vendor":"openpos","product":"OpenPOS Lite – Point of Sale for WooCommerce","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/e3bb88e9-e410-4ff7-b342-72c7b375dff1?source=cve","https://plugins.trac.wordpress.org/browser/wpos-lite-version/trunk/includes/admin/Admin.php#L3161","https://plugins.trac.wordpress.org/browser/wpos-lite-version/tags/3.0/includes/admin/Admin.php#L3161","https://plugins.trac.wordpress.org/changeset/3456299/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:11:10.572Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/1xxx/CVE-2026-1826.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-1826","state":"PUBLISHED","datePublished":"2026-02-11T08:26:27.919Z","dateUpdated":"2026-04-08T17:29:27.754Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-02-03T14:23:09.751Z"},"containers":{"cna":{"title":"OpenPOS Lite <= 3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes","descriptions":[{"lang":"en","value":"The OpenPOS Lite – Point of Sale for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'width' parameter of the order_qrcode shortcode in all versions up to, and including, 3.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"openpos","product":"OpenPOS Lite – Point of Sale for WooCommerce","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/e3bb88e9-e410-4ff7-b342-72c7b375dff1?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wpos-lite-version/trunk/includes/admin/Admin.php#L3161"},{"url":"https://plugins.trac.wordpress.org/browser/wpos-lite-version/tags/3.0/includes/admin/Admin.php#L3161"},{"url":"https://plugins.trac.wordpress.org/changeset/3456299/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:29:27.754Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Yudha - DJ"}],"timeline":[{"time":"2026-02-10T20:07:08.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-02-11T15:37:02.304120Z","id":"CVE-2026-1826","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-02-11T15:44:27.667Z"}}]}}}